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1 Acknowledgements
This plugin contains code and/or ideas from the following sources:

- Raw radar data aircraft shapes are based on Pierre Ferran’s work on his vSMR plugin
- JSON parsing uses the JSON for Modern C++ library
- File transfers use the libcurl library

2 Getting started

The Ground Radar plugin has two modes. “Ground” mode is based on the SAAB A3000 A-SMGCS system,
and “Tower” mode on the SAAB RDP air situation display. Some settings are required in the used ASR file to
determine which mode to use, and to set up some of the necessary parameters.

The plugin can be set up to represent one of two software versions. Their functionality is the same, the only
difference is how windows, menus and lists appear on the screen. The images in this document are from
the default GUI version (System_GUI_Version=0).

If the plugin was provided in a package, all the necessary settings are most likely set already. If not, refer to
the Developer Guide for information on how to install and set up the plugin.

The plugin requires the MSVC++ Redistributable package to be installed. Without it, the plugin will either
fail to load at all, or crash while trying to load.

2.1 Plugin updates

On startup, the plugin will attempt to check for updates. If the check fails or a new version is available, a
message box will be presented. In case a mandatory update exists and the latest date to update has already
passed, the plugin features will be blocked until it is updated.

When an update is available, the message box will show where to download the current version. The
update package contains the plugin dll, the current manual set and the plugin data files that are common to
all setups. Replace the existing files with the new ones but do not delete any files unless specifically asked
to do so.



https://github.com/pierr3/vSMR
https://github.com/nlohmann/json
https://curl.haxx.se/libcurl/
https://aka.ms/vs/17/release/vc_redist.x86.exe

3 Global Menu

3.1 Pin
Left-click to toggle permanently displaying the Global Menu on the screen. A box will be displayed around

the pin symbol when so. When not permanently displayed, the Global Menu will be hidden when the cursor

is outside the menu area and none of its submenus are open.

3.2 Settings menu

3.2.2

Units
Display
Labels
Lists

Raw Video

V V V V V

Units submenu
Altitude

- reference
Flight level
Distance
Speed

Display submenu

3.2.2.1 Ground mode

Surveillance - - - - - ------------
o Promode

Tracks ---------c-ccoeooo-
o Display
o History
o HDG line
o AltFilter
Label Filters - ----------------
Stby
o SqError
o NoState
o OnFreq
o Parked

Opens the Units submenu

Opens the Display submenu

Opens the Labels submenu

Opens the Lists submenu (Ground mode only)
Opens the Raw Video submenu (Ground mode only)

Toggles displaying altitudes in feet or meters

Toggles the altitude reference between QNH and QFE
Toggles displaying flight levels in feet or meters

Toggles displaying distances in nautical miles or kilometers
Toggles displaying speeds in knots or kilometers per hour

Toggles the Pro mode on/off

Toggles the label, track symbol, history dots and heading line on/off
(Can’t be set off if Settings > Raw Video > Raw Video is also off)
Sets the number of history dots to display (0-19)

Toggles the heading line on/off

(The heading line is a 10 pixels long line drawn from the position
symbol showing the heading of the aircraft)

Hides tracks above specified height above airport elevation

in 100’s of feet (001-999) or meters (00030-30450)

Toggles display of labels for tracks with transponder in standby
Toggles display of labels for tracks not squawking assigned code
Toggles display of labels for departures with no ground state
Toggles display of labels for departures with state ON FREQ
Toggles display of labels for arrivals with ground state PARKED

The ‘Pro mode’ setting determines what data will be displayed and how the radar tracks are correlated to

flight plans. With the setting off, the airport area will have perfect primary and secondary radar coverage

and all the aircraft are shown correctly correlated.



When ‘Pro mode’ is selected on, the radar coverage depends on the plugin and EuroScope setup, and for

the correlation the plugin first checks mode S availability (radar coverage and flight plan equipment suffix).

If available, it will be used for correlation. If not, the correlation state as reported by EuroScope (depending

on the ‘Professional mode’ settings in EuroScope’s General Settings) will be used.

The five label filtering options only apply to stationary tracks. The filters can be temporarily disabled by

moving the mouse cursor over an empty part of the Global Menu. When the cursor leaves the area, the

filters will be automatically re-enabled.

3.2.2.2 Tower mode

- Surveillance-----------------
o Promode

- Tracks---------coooooo.
o History
o Prediction
o Filter Hi
o Filter Lo

3.2.3 Labels submenu

- Position--------------------
o X
o Y

- Fields---------c-cmmoon--
o <FieldName>

3.2.4 Lists submenu

- Alerts
- ARR
- DEP

- Dep Timer

- Maps
- Stands
- TTT

V V V V VvV V V

Toggles the Pro mode on/off

Sets the number of history dots to display (0-19)

Sets the length of the prediction line in minutes (0-99)
Hides labels above specified level

in 100’s of feet (-010-999) or meters (-305-30450)
Hides labels below specified level

in 100’s of feet (-010-999) or meters (-305-30450)

Sets the default label position x-offset in pixels (positive right)
Sets the default label position y-offset in pixels (positive down)

Toggles the <FieldName> field on/off

The Lists submenu provides access to changing some list parameters. For each, the options may contain:

=  <FieldName>

3.2.5 Raw Video submenu

- Display

- Brightness

Number of items to display

Toggles the <FieldName> column on/off

Toggles the raw video display on/off

(Can’t be set off if Settings > Display > Tracks > Display is also off)
Adjusts the general brightness of the radar returns (1-100)
(Note that if the Ground Label is set “off”, having a low



Afterglow
History

3.3 Window menu

brightness setting may make it very hard to see the traffic)
Controls how fast the returns fade (0-100)
Sets the maximum number of history positions (0-10)

- 2nd, 3rd, ... Opens the respective Traffic Situation Window

- APP1,APP2, .. Opens the respective Approach Window

- Approach Path > Opens an Approach Path Window (select approach from list)
- TIT > Opens a Time To Threshold List (select runway from list)
- Dep Timer > Opens a Departure Timer List (select runway from list)

- Lists > Opens the Lists submenu

- Runway Conf Opens the Runway Configuration Window

- RVR Opens the RVR Window

- QNH Opens the QNH Window

- METAR Opens the METAR Window

- Wind Rose > Opens a Wind Rose Window (select runway from list)

The items in the menu are active only in the ground mode of the plugin. Traffic Situation, Approach and

Approach Path windows are only shown when at least one has been enabled in the plugin settings.

3.3.1

Lists submenu
ARR

Opens the Arrival List

- DEP Opens the Departure List
- Stands Opens the Stands List

3.4 Functions menu

Flight Plan
Text notes
Map Selection

Opens the Flight plan setting dialog (enter callsign)
Opens the Text notes submenu
Opens the Map Selection Window

(Lists only maps defined to be visible on the main screen)

3.4.1 Textnotes submenu
- Create... Creates a new text note
- Delete... Deletes a single text note
- Delete all Deletes all text notes

It is possible to insert text notes on the radar screen to act as reminders. They will stay fixed at the

geographical coordinates they are inserted to, the coordinates defining the center point of the note.

When creating a note, a text entry field opens to enter the note text. When the [Enter] key is pressed, the
note will be created at the current mouse cursor position.

The notes can be deleted one by one or all of them at the same time. When deleting one by one, the notes
are boxed to display their click areas. Clicking on one will delete the note. Pressing the [Esc] key or selecting
the “Delete...” menu item again will abort the operation.



3.5 Alerts

Displays a filled warning triangle whenever there is at least one alert active, hollow otherwise. Left-clicking
the symbol opens the Alerts List.

3.6 QNH
Displays the latest QNH if a METAR for the airport has been received by EuroScope. When the QNH
changes, the background will be set to yellow color. Left-click to acknowledge the change.

3.7 Low Visibility Procedures status
Left-click to toggle between “NORMAL” and “LVP”. This sets the runway related alert settings accordingly
and may be used for automatic map activation.

3.8 Safety Nets

- APM Toggle APM alerts on/off
- APW Toggle APW alerts on/off
- RIM Toggle RIM alerts on/off

- CBM Toggle CBM alerts on/off
- ICm Toggle ICM alerts on/off

- 0OSM Toggle OSM alerts on/off
- RVM Toggle RVM alerts on/off
- ECM Toggle ECM alerts on/off
- RUM Toggle RUM alerts on/off

When a safety net is switched off, its button is shown with a yellow background. See the Safety Nets
chapter for information on which alerts are connected to which system.



3.9 Developer menu
Depending on the GUI mode, left-click on either the blue “HITT” label or the round logo to open the menu

- Reload Settings Reloads the information in the settings files
- Reload Data Files Reloads the information in the data files
- Show/Hide Airport Data Toggles airport related data display on/off

When selected on, the airport data displays the following for development use:

- On mouse-over, Traffic Situation Windows, Approach Windows and Approach Path Windows
display some of their current setting values to help with settings file setup.
- Airport reference point (green crosshairs and circle), ICAO code and elevation
- Airport area, i.e. airport radius circle around the reference point (green dotted line)
- Runway end and threshold locations (marked with runway id in red color)
- Runway areas (red polygons, LVP versions with dotted lines)
- Runway buffer areas (yellow polygons, LVP versions with dotted lines)
- Runway crossings (red crosses)
- Aircraft stands
Occupied and blocked in red

o Assigned in yellow
o Free but blocked from automatic assignment in dotted green
o Free and available for automatic assignment in solid green



4 Track presentation

In both the ground and tower modes, the track symbols and labels are colored according to the flight’s
status (arrival, departure or overflight/unknown). By default, the arrivals are yellow, departures light blue
and overflight/unknown tracks light grey. In the tower mode also the history dots and prediction lines use
the same coloring. In the ground mode all history dots use the overflight/unknown color and there is no
prediction line available. Hovering the mouse cursor over a label will show all data fields even if not
selected on in the settings. The symbols and track labels displayed here are the default sets.

4.1 Ground mode

4.1.1 Track symbol
-0 Primary track
- 0O Secondary (mode A or S) or combined track

Right-clicking on the track symbol toggles the heading line

4.1.2 Uncorrelated track label

ALRT
CALLSIGN FLTID

- ALRT Safety net alert indicator
- CALLSIGN Transponded SSR code (“----" for primary tracks)
- FLTID Mode S downlinked callsign

4.1.3 Correlated track label

Departure Arrival Overflight/unknown
ALRT FLTID_E ASSR_E COMM ALRT FLTID_E ASSR_E COMM ALRT FLTID_E ASSR_E COMM
CALLSIGN DRWY DEP CALLSIGN STAND CALLSIGN
ATYP WTC MALRT RMK ATYP WTC MALRT RMK ATYP WTC MALRT RMK
- ALRT Safety net alert indicator
- ASSR_E Assigned SSR code if different from the transponded code
- ATYP Aircraft type
- COMM “t” if text only, “r” if voice receive only
- CALLSIGN Callsign
- DRWY Departure runway identifier, automatically displayed when either:

e there is more than one active departure runway, or
e RUM is enabled and the assigned runway is not an active departure runway

- DEP Assigned heading or SID designator

- FLTID_E “S” (unselected)/mode S callsign (selected) if different from correlated flightplan callsign
- MALRT Manual alerts

- RMK Scratchpad contents

- STAND Assigned arrival stand

e Highlighted after a change until acknowledged
- WTC Wake turbulence category




4.2 Tower mode

4.2.1 Track symbol
- D Primary track
- u Uncorrelated secondary or combined track
R Correlated secondary or ADS-B only track
e

- Correlated combined track

Note: Tracks with only a mode S return (no primary or mode A data) are considered ADS-B only.

4.2.2 Uncorrelated track label

CALLSIGN FLTID

AFL+VS GS
- AFL+VS Actual flight level and an arrow to indicate climb or descent
e altitudes prefixed by “A”
- CALLSIGN Transponded SSR code
- FLTID Mode S downlinked callsign
-GS Groundspeed in knots (rounded to nearest 10 knots)

4.2.3 Correlated track label

A
CALLSIGN COMM
AFL+VS GS

MALRT RMK
- A Manual alerts flag
- AFL+VS Actual flight level and an arrow to indicate climb or descent

e altitudes prefixed by “A”

- CALLSIGN Callsign
- COMM “t” if text only, “r” if voice receive only
-GS Groundspeed in knots (rounded to nearest 10 knots)
- MALRT Manual alerts
- RMK Scratchpad contents

4.3 Label field mouse functions
The following mouse functions are available (left-click unless specified):

- ARWY Open runway setup popup list
- CALLSIGN Open Callsigh menu
- DEP Left-click: Open SID setup popup list
Right-click: Open assigned heading popup list
- STAND New assignment: Acknowledge it
Otherwise: Open Stand assignment menu
- RMK Edit scratch pad string

10



5 Tracklabel menus

5.1 Callsign menu

The Callsign menu for correlated tracks contains the following (unavailable ones shown with grey text):

<Ground state>
- Assume

- Trans<ID>

- Man Tfr

- Free

- FPL

- Stand

- Uncorrelate
- [] MissedApp
- [l Inbd Est

- []lrregular

- [] Weather

(Displays current ground state) Opens the Ground state menu

Assumes the track

Transfers the track to the indicated controller

Opens a menu to manually transfer the track to any controller
Drops the track

Opens the EuroScope Flight plan setting dialog

Opens the Stand assignment menu

Uncorrelates the flight plan from the radar track
Toggle “Missed approach” manual alert

Toggle “Inbound estimate” manual alert

Toggle “Irregular” manual alert

Toggle “Weather” manual alert

For uncorrelated tracks, the menu only contains one item:

- Correlate

Correlate the radar track with a flight plan (enter the callsign)

5.2 Ground state menu
The Ground state menu includes the default and custom ground states:

Departure:

- ON FREQ
- DEICE

- START UP
- PUSH

- TAXI

- LINEUP

- TAKE OFF

- (empty)
Arrival:

- TAXI
- PARKED

- (empty)

Sets the custom “On Freq” state

Sets the custom “De-Ice” state

Sets the default or custom “Start-Up” state depending on EuroScope version
Sets the default “Push” state

Sets the default “Taxi Out” state

Sets the custom “Line Up” state

Sets the default “Depa” state

Clears the ground state

Sets the default “Taxi In” state
Sets the default “Parked” state
Clears the ground state

For compatibility reasons, the custom states set the following default states:

- OnFreq
- De-Ice

- LineUp
- (empty)

Clears any default state if one had already been set
Clears any default state if one had already been set
“Taxi Out”

Departure: Clears any default state if one had already been set

Arrival: If “Parked” state had been set, sets “Taxi In”.
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5.3 Stand assignment menu
The Stand assignment menu is used for various tasks related to arrival stand assignment. It will not open if
another controller is tracking the aircraft. The menu contains the following options:

- Auto Assigns a new arrival stand automatically

- Manual Opens the Manual stand assighnment menu

- Publish Communicates the current stand assignment to other controllers
- Clear Clears the stand assignment

In addition to the manual “Publish” method to communicate stand assignments, an assignment is
automatically communicated to all controllers in range when the assignment is made, when the aircraft is
transferred or dropped using the Callsign menu functions, and also using the flight strip when the track is
transferred (by this method only to the next controller).

5.4 Manual stand assignment menu

This menu lists the stands at the airport for manual assignment. Stands that are occupied, blocked or
already assigned are displayed in grey color. The “[---]” item allows to manually type in the stand
designator.

12



6 Windows

To move a window, drag it from the title bar. To close it, click on the [X] button in the top right corner. To
resize (where available), drag the box in the bottom right corner. To move a window on top of all other
windows and lists, left-click on the title bar. To move it below all others, right-click the title bar.

6.1 Traffic Situation Window
Global Menu -> Window -> 2nd, 3rd, ...

TSW2 = H X

-

Additional Traffic Situation Windows can be opened to display other views of the airport. The windows can
be set up to display the same background as the primary one but it requires specific plugin maps to be
created. The number of additional windows available depends on the setup, by default there is one.

To pan the view, drag somewhere on the display area. Left-double-clicking centers the view on that
position. Right-clicking on the window background area opens a window menu.

Left-clicking on the [+] button zooms the display in, [-] zooms it out. The available zoom range is 1-100000
pixels/nm, the initial value being 100 pixels/nm. Each click increases or decreases the scale by 25%. The
mouse wheel can also be used for zooming.

6.1.1 Window menu

- Display > Opens the Display submenu
o General--------------
=  Rotation Rotates the view (-360.0 to 360.0 degrees or empty to set “auto”)
(“Auto” rotation sets the rotation to match the primary window)
o Tracks---------------
= Display Toggles the label, track symbol, history dots and heading line on/off.
(Can’t be set off if Raw Video > Raw Video is also off)
= History Sets the number of history dots to display (0-19)
= HDG line Toggles the heading line on/off

(The heading line is a 10 pixels long line drawn from the position
symbol showing the heading of the aircraft)

= AltFilter Hides tracks above specified height above airport elevation
in 100’s of feet (001-999) or meters (00030-30450)

o Label Filters-----------
=  Stby Toggles display of labels for tracks with transponder in standby
= SqError Toggles display of labels for tracks not squawking assigned code

13



= NoState Toggles display of labels for departures with no ground state

= OnFreq Toggles display of labels for departures with state ON FREQ
= Parked Toggles display of labels for arrivals with ground state PARKED
- Labels > Opens the Labels submenu
o Position--------------

= X Sets the default label position x-offset in pixels (positive right)
= Y Setsthe default label position y-offset in pixels (positive down)

o Fields----------------
= <FieldName> Toggles the <FieldName> field on/off
- Raw Video > Opens the Raw Video submenu
o Display Toggles the raw video display on/off.
Can’t be set off if Display > Tracks is also off.
o Brightness Adjusts the general brightness of the radar returns (1-100).
Note that if the Display > Tracks is set “off”, having a low
brightness setting may make it very hard to see the traffic.
o Afterglow Controls how fast the returns fade (0-100)
o History Sets the maximum number of history positions (0-10)
- Maps > Opens the Map Selection Window

(Lists only maps defined to be visible on TSWs)

The selections in the Labels submenu are synced between all Traffic Situation Windows and the primary
window. By default, the other selections (besides Rotation) are as well, but they can also be set to be
window-specific.

14



6.2 Approach Window
Global Menu -> Window -> APP 1, APP 2, ...

AFP dH M

——L——11&nm

T N

S,

Izil\.l’-"LRC 03RV

-

The Approach Windows display traffic around the airport (traffic on the ground at the airport is hidden).
The window displays the runway centerlines, and optionally extended centerlines and various maps. The
number of Approach Windows available depends on the setup, by default there is one.

To pan the view, drag somewhere on the display area. Left-double-clicking centers the view on that
position. Right-clicking on the window background area opens a window menu.

Left-clicking on the [+] button zooms the display in, [-] zooms it out. The available zoom range is 1-100
pixels/nm, the initial value being 10 pixels/nm. Each click increases or decreases the scale by 25%. The
mouse wheel can also be used for zooming.

The arrow below the scale, shown if the display has been rotated, points to true north.
Hovering the mouse cursor over a label will display all data fields even if not selected on in the settings.

For the mouse functions in labels, refer to Label field mouse functions.

6.2.1 Uncorrelated track label

ALRT
CALLSIGN FLTID
AFL GS
- AFL Actual flight level
e altitudes prefixed by “A”
- ALRT Safety net alert indicator
- CALLSIGN Transponded SSR code
- FLTID Mode S downlinked callsign
- GS Groundspeed in knots

15



6.2.2 Correlated track label
Departure

Arrival

Overflight/unknown

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN DRWY DEP

AFL GS

ATYP WTC RMK

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN ARWY STAND

AFL GS

ATYP WTC RMK

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN

AFL GS

ATYP WTC RMK

- AFL

Actual flight level

e altitudes prefixed by “A”

- ALRT
- ARWY

Safety net alert indicator
Arrival runway identifier, automatically displayed when either:

e there is more than one active arrival runway, or

e the assigned runway is not an active arrival runway

- ASSR_E
- ATYP

- COMM

- CALLSIGN
- DRWY

“t” if text only,

Assigned SSR code if different from the transponded code
Aircraft type

“ n
r

if voice receive only

Callsign
Departure runway identifier, automatically displayed when either:

e there is more than one active departure runway, or

e the assigned runway is not an active departure runway

- DEP
- FLTID_E
-GS

- MALRT

- RMK

- STAND

Assigned heading or SID designator

“S” (unselected)/mode S callsign (selected) if different from correlated flightplan callsign
Groundspeed in knots

Manual alerts

Scratchpad contents

Assigned arrival stand

e Highlighted after a change until acknowledged

- WITC

6.2.3 Window menu

- Display >

o General---------

= Rotation

o Tracks----------

= History
=  Prediction

=  Extensions

= AltFilter
- Labels >
o Position---------
= X
=Y
o Fields----------

Wake turbulence category

Opens the Display submenu

Rotates the view (-360.0 to 360.0 degrees or empty to set “auto”)
(“Auto” rotation sets the rotation to match the primary window)

Sets the number of history dots to display (0-19)

Sets the length of the prediction line in minutes (0-99)

Sets the extended centerlines length

in nautical miles or kilometers (0-999)

Hides labels above specified level

in 100’s of feet (000-999) or meters (00000-30450)

Opens the Labels submenu

Sets the default label position x-offset in pixels (positive right)
Sets the default label position y-offset in pixels (positive down)

16




= <FieldName> Toggles the <FieldName> field on/off
- Maps > Opens the Map Selection Window
(Lists only maps defined to be visible on Approach Windows)

The selections in the Labels submenu are synced between all Approach Windows. By default, the other
selections (besides Rotation) are as well, but they can also be set to be window-specific.

6.3 Approach Path Window
Global Menu -> Window -> Approach Path -> (select approach)

15 Approach Path e

NW558T

/

-

The Approach Path Window displays a vertical and horizontal view of a pre-defined approach. Distance
lines are shown at 1 nm intervals. Having an Approach Path Window open activates Approach Path
Monitoring for that approach, if the alert parameters have been defined in the settings.

Hovering the mouse cursor over a label will display all data fields even if not selected on in the settings.
Right-clicking on the window background area opens a window menu.

For the mouse functions in labels, refer to Label field mouse functions.

6.3.1 Window menu

- Display > Opens the Display submenu
o Tracks---------------
=  History Sets the number of history dots to display (0-19)
=  Prediction Sets the length of the prediction line in seconds (0-999)
- Labels > Opens the Labels submenu
o Position--------------
= X Sets the default label position x-offset in pixels (positive right)
=Y Sets the default label position y-offset in pixels (positive down)
o Fields----------------
= <FieldName> Toggles the <FieldName> field on/off

All selections in the menu are synced between all Approach Path Windows.
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6.3.2 Uncorrelated track label

ALRT
CALLSIGN FLTID
AFL GS

- AFL

- ALRT

- CALLSIGN
- FLTID
-GS

Actual flight level

e altitudes prefixed by “A”
Safety net alert indicator
Transponded SSR code
Mode S downlinked callsign
Groundspeed in knots

6.3.3 Correlated track label

Departure

Arrival

Overflight/unknown

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN DRWY DEP

AFL GS
ATYP WTC RMK

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN ARWY STAND

AFL GS

ATYP WTC RMK

ALRT MALRT FLTID_E ASSR_E COMM
CALLSIGN

AFL GS

ATYP WTC RMK

- AFL Actual flight level
e altitudes prefixed by “A”
- ALRT Safety net alert indicator
- ARWY Arrival runway identifier, automatically displayed when either:
e there is more than one active arrival runway, or
e the assigned runway is not an active arrival runway
- ASSR_E Assigned SSR code if different from the transponded code
- ATYP Aircraft type
- COMM “t” if text only, “r” if voice receive only
- CALLSIGN Callsign
- DRWY Departure runway identifier, automatically displayed when either:
e there is more than one active departure runway, or
e the assigned runway is not an active departure runway
- DEP Assigned heading or SID designator
- FLTID_E “S” (unselected)/mode S callsign (selected) if different from correlated flightplan callsign
- GS Groundspeed in knots
- MALRT Manual alerts
- RMK Scratchpad contents
- STAND Assigned arrival stand
e Highlighted after a change until acknowledged
- WTC Wake turbulence category
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6.4 Runway Configuration Window
Global Menu -> Window -> Runway Conf

[RWY Conf
RWY MODE
a4L

B4R

15 ARR

22L

22R DEP

33

The Runway Configuration Window displays the current activity state of the airport’s runways as either
“DEP”, “ARR”, “MIX”, “CLOSED” or “N/U”.

6.5 RVR Window
Global Menu -> Window -> RVR

[RVR |
STRIP RVR RVR
B4L722R 1588
B4R/ 221 8558u
15733 28880

The RVR Window displays the RVR values if available in a received VATSIM METAR. For values reported as
variable, the minimum value is shown.

6.6 QNH Window
Global Menu -> Window -> QNH

QNH X
QNH

GMH | 1@13 hPa 2991 inHg 759 mmHg

ONH .

-

1813“"3 l@@ﬁhpa 29711’|‘|Hg 754"Hg

The QNH window displays the current QNH value if available in a received VATSIM METAR. Left-clicking the
“QNH” text in the top left corner below the title bar toggles the display of QFE. Left-clicking the pressure
units label toggles the display of other pressure units (inHg if the METAR value is in hPa and vice versa, and
mmHg).
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6.7 METAR Window
Global Menu -> Window -> METAR

METAR e
EFHK 16122607 288168KT CAVOK 84/82 Q1@13|—

The METAR window displays the latest received VATSIM METAR.

6.8 Wind Rose Window

Global Menu -> Window -> Wind Rose -> (select runway)

WIND ROSE P
15 Visibility CAVOK
. Ry
- ¥
,#335 W/ ‘\‘ RVR TDZ --
F S END -
;388 . 68 ‘-"
Nz7e- 2?% CEY | Rain |
v, 107 |
(L 12E:Jr Cloud CAVOK
"‘EE 188 Hfr"" FE 1007 HPA
o= 1 B
R:EH_SK_

The Wind Rose window displays the weather from a received VATSIM METAR. The basic display shows only
the wind information. Average wind is displayed in the center, gusts — if reported — in the bottom left
corner, and wind components in the bottom right corner. Variable wind direction is indicated by coloring
the relevant sectors of the wind rose with a different color.

Left-clicking the panel with a triangle symbol in the right edge of the window toggles an extended weather
display, showing the visibility, RVR, precipitation type, cloud layers, and optionally the QFE (if the runway
threshold elevation has been defined in the plugin settings).

6.9 Clock Window

Global Menu -> left-click on the date/time area

Clock =

13:02:57

The Clock window displays the current UTC date and time.
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6.10 Map Selection Window

Global Menu -> Functions -> Map Selection

Traffic Selection Window -> Window menu -> Maps
Approach Window -> Window menu -> Maps

MAP SELECTION TSW pat
v o Runways
“a B@4L722R
a @4RF22L
+m 15733
+ FATOLG/34
> + RWwyClosed
= 4 System
v

TwyClosed
= A
v B
ED
EW

The Map Selection Window is used to select maps for display. It can contain a number of folders, subfolders
and maps within them. It will only list maps available in the window it was opened from.

Folders: Displayed as <state> <mapinfo> <name>, where:

- <state> displays the folder state:

o > closed
oV open
- <mapinfo> displays map activity information:
o Vv the folder contains at least one active map
o (empty) the folder contains no active maps

- <name> displays the folder name
Left-click the line to toggle the folder between closed and open.
Maps: Displayed as <state> <name>, where:

- <state> displays the map state:
o maps with automatic activation

= Va active, automatic mode

= Vm active, manual mode

= a inactive, automatic mode
"= m inactive, manual mode

o maps without automatic activation
= W active
= (empty) inactive
- <name> displays the map name

Left-click the line to toggle the map state between active and inactive. If the map is in automatic mode, left-clicking
will also set it to manual mode.

For maps with automatic activation, right-clicking the line toggles the map between automatic and manual mode.
When changing from automatic to manual mode, the current activation state is kept.
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7 Lists

To move the lists, drag from the title bar. To close them, click on the [X] button in the top right corner.

When a scrollbar is displayed, the displayed items can be scrolled one at a time by using the “up” and
“down” triangle buttons above and below the scrollbar, by dragging the scrollbar or by clicking the scrollbar
area above or below the scrollbar itself (left-clicking scrolls by the number of items displayed, right-clicking
moves the scrollbar to the clicked position). Columns in BOLD text below cannot be toggled on/off.

7.1 Time To Threshold List

Global Menu -> Window -> TTT -> (select runway)

15 TWEOUND b
11T C/5 DTT TYPE W SSE  RULE ETA STAND
B2:53 NWS587 8.8 B738 M 2784 1 12:56 547

The Time To Threshold List displays a list of aircraft approaching that runway. The aircraft are added to the
list when they are established on the extended centerline (less than 0.6nm cross track error and ground
track within 20 degrees of the runway heading), are less than 30nm from the threshold and at an altitude
not more than 5000ft above the airport elevation. The list is sorted according to distance from the
threshold, with the closest aircraft at the top.

When an aircraft is on final to a runway other than the one it is supposed to land on, it will be added to the
list when it is a bit closer to the threshold, when the plugin code assumes that it will land on the runway
regardless of the runway assignment (less than 0.3nm cross track error, ground track within 10 degrees of
the runway heading and less than 4nm from the runway threshold).

- TIT Time to threshold (mm:ss) assuming current groundspeed
- C/S Callsign

- DTT Distance to threshold (nm or km)

- TYPE Type

- W Wake turbulence category

- ETA Estimated time of arrival

- STAND Assigned arrival stand
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7.2 Departure Timer List
Global Menu -> Window -> Dep Timer -> (select runway)

22R QUTBOUND |
DT C/5 TYPE W S5R RULE 5ID ADES
00:47 IBK124 B738 M 5233 1 TEVRU4N EFRO
84:58 FIN245P A3280 M 6847 I TEVRU4N EFRO

The Departure Timer List displays aircraft that have recently departed from that runway. The aircraft are

added to the list when their groundspeed exceeds 40 knots and are automatically removed after a defined
time, 10 minutes by default. They can also be manually removed at any time by left-double-clicking on the
DT field. The list is sorted according to departure time, with the most recently departed aircraft at the top.

- DT Elapsed time (mm:ss) from departure
- C/S Callsign

- TYPE Type

- W Wake turbulence category

- SID SID designator

- ADES Destination ICAO code

7.3 Alerts List

Global Menu -> left-click on warning triangle

[ALERTS ]
C/S ALERT

= [#] dxX1 Clearance
C-AIDA No taxi cl

The Alerts List displays the active alerts and informations provided by the safety nets. The list is sorted to
display the alerts first, sorted according to the callsign, and then the informations.

- C/s Callsign
- ALERT Alert or information type

It is possible to cancel APM “Area penetration” and RVM “Restriction” alerts for a stationary track by left-
clicking the callsign in the Alerts List. The alerts will be automatically activated again when the track starts

moving.

23



7.4 Arrival List
Global Menu -> Window -> Lists -> ARR

ARR |
RWY C/5S TYPE W SS5R RULE ADEP ETA STAND CLEARANCE
15 NWS587 B738 M 2784 1 UUEE 13:83 547

The Arrival List displays flights inbound to the airport, estimated to arrive within the next 60 minutes. The
list is by default sorted according to ETA. The other available sorting option is C/S. Click on the respective
column title to sort based on it, left-click for ascending, right-click for descending.

Setting a flight’s ground state to “Parked” will remove it from the list.

Column Left-click mouse action
- Rwy Arrival runway Open runway setup popup list
- C/S Callsign Open Callsign menu
- TYPE Type
- W Wake turbulence category
-SSR Assigned transponder code
- RULE Flight rules
- ADEP Departure airport ICAO code
- ETA Estimated time of arrival
- STAND Assigned arrival stand Open Stand assignment menu
- CLEARANCE Ground state Open Ground state menu
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7.5 Departure List
Global Menu -> Window -> Lists -> DEP

DEF it
C/5 TYPE W 55 RULE EOBT STAND ADES RWY SID CLEARAMNCE
BAW136K A31S M I 15:18 EFRO 22R TEVRU4N Taxi
FIN24VR A31S M I 17:68 EFRO 22R TEVRU4N Taxi
FIMGEE A315 M 68518 I ge:08 EFRO 22R TEVRU4N Take off
FINV A315 M 3615 1 17:28 12 EFRO 22R TEVRU4N

FINSPE A315 M 20811 I 17:308 21 EFRO 22R TEVRU4N

FHNIS2T A319 M I 17:48 28 EFRO 22R TEVRU4N

The Departure List displays flights departing from the airport. The list is by default sorted alphabetically on

C/S. The other available sorting options are EOBT and CLEARANCE. Click on the respective column title to

sort based on it, left-click for ascending, right-click for descending.

Column
c/s
TYPE

w

SSR
RULE
EOBT
STAND
ADES
RWY
SID
CLEARANCE

Callsign

Type

Wake turbulence category
Assigned transponder code
Flight rules

Estimated off-block time
Departure stand
Destination airport ICAO code
Departure runway

SID designator

Ground state

Left-click mouse action

Open Callsigh menu

Open Manual stand assignment menu

Open SID setup popup list
Open Ground state menu
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7.6 Stands List

Global Menu -> Window -> Lists -> Stands

EFHK STANDS i
STAND PARKED INEOUND
28 FIN24VR

21 SASB268

22 J
23

24

25

26

27 EIN125
28

29

The Stands List shows an overview of the stand allocation status at the airport. It also allows to manually
assign arrival stands, mark stands as occupied by a specific aircraft, or to block stands from automatic
allocation. Blocked stands are displayed with grey text if automatically blocked, red text if manually
blocked.

In addition to the Settings menu, the number of displayed stands can be adjusted by dragging the “down”
triangle button below the scrollbar when it’s visible.

Column Left-click mouse action
- STAND Stand designator Toggle manually blocked status
- PARKED Parked aircraft callsign Open a menu to mark the stand occupied by an

aircraft, or to clear the information when it exists
- INBOUND Inbound aircraft callsign Open a menu to manually assign the stand

Stands defined as an area (capable of parking multiple aircraft) will display the number of aircraft parked
and assigned to park there in the “PARKED” and “INBOUND” columns. It is not possible to manually set an
area stand as occupied by an aircraft.

The “Parked” menu shows all aircraft within 5nm of the airport reference point, and the “Inbound” menu
all aircraft arriving at that airport regardless of distance to the airport. When assigning a stand, it may take
a couple of seconds until it shows in the window as the stand assignments are refreshed every 5 seconds
within the plugin.
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8 Safety Nets

In the ground mode of the plugin, the following potentially unsafe situations are highlighted by presenting
an alert indication in the track label. If more than one alert is active simultaneously, the first one in the
below order is shown. The alerts are also shown in the Alerts List, and by coloring the callsign item
appropriately in other lists. The safety nets can be toggled on/off using the buttons on the Global Menu
bar. The button that controls each alert is shown boxed before the alert name in the list below.

8.1 Runway Monitoring and Conflict Alerting (RMCA)

RMCA displays conflicts between aircraft on a runway or on approach. In addition to monitoring single
runways, it also looks for conflicts on crossing runways. Whether the conflict is shown as an alert or
information depends on its severity (closure rate, time to threshold, etc.)

CONFLICT RMCA conflict alert

CONFLICT RMCA conflict information

8.2 Conformance Monitoring Alerts for Controllers (CMAC)
CMAC provides alerts when aircraft deviate or potentially deviate from clearances or normal procedures.

NO TOF CLR No take-off clearance alert

Departing aircraft above 20kts ground speed on runway without “DEPA” state

RWY INCURSION Runway Incursion Monitoring alert

Departing aircraft on:

- its departure runway with a ground state other than “LINE UP” or “DEPA”

- another runway with a ground state other than “TAXI”

- any runway with a ground state other than “TAXI”, “LINE UP” or “DEPA”
when no departure runway has been set

Arriving aircraft on:

- a runway other than its arrival runway with a ground state not “TAXI IN”

- any runway with a ground state other than “TAXI IN” when no arrival runway
has been set

HIJACK Emergency Code Monitoring alert

COMFAIL Displayed for squawks 7500, 7600, 7601 * and 7700 within 30nm of the airport
COMFAIL VMC *) 7601 optional, can be disabled in settings

RWY CLOSED Runway closed alert

Aircraft on a closed runway
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AP
APW|

TWY CLOSED

STATIONARY RPA

RWY CLOSED

RWY TYPE

NO CONTACT

TRANSFER?

HIGH SPEED

NO TAXI CLR

NO PUSH CLR

Runway type alert

Aircraft on a runway not suitable for it

Taxiway type alert

Aircraft on a taxiway not suitable for it

Approach Path Monitoring alert
Aircraft deviating from an approach path either laterally or vertically

Area Proximity Monitoring alert

Aircraft inside an area prohibited for all traffic

Restriction Violation Monitoring alert
Aircraft inside an area prohibited for it

Taxiway closed alert

Aircraft on a closed taxiway

High speed alert

Aircraft moving very fast (over 55kts ground speed) outside a runway

Stationary within the runway protected area alert
Arriving aircraft stopped inside a runway protected area

Runway closed information

Aircraft assigned a closed runway

Runway type information

Aircraft assigned a runway not suitable for it

No contact information

Arriving aircraft still in “transfer in” state, less than 120sec/4nm to threshold

No transfer information

Departing aircraft still assumed and outside a defined volume
(height above airport elevation, distance from reference point)
(applicable only when logged in as GND or TWR)

High speed information

Aircraft moving fast (40-55kts ground speed) outside a runway

No taxi clearance information

Departing aircraft moving forward with ground state “none”, “ON FREQ”,
“DEICE” or “START UP”, or over 10kts ground speed with ground state “PUSH”

No pushback clearance information
Departing aircraft moving backward with ground state “none”, “ON FREQ”,

“DEICE” or “START UP”
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DUPE

Duplicate squawk code infomation
Duplicated mode A codes within 100nm of the airport

Occupied Stand Monitoring alert
Arriving aircraft whose stand is currently occupied
(This alert is only displayed on the track label)

Runway Usage Monitoring alert
Arriving aircraft assigned an arrival runway that is not active for arrivals when

there is at least one active arrival runway
(ARWY item shown with a red background)

Runway Usage Monitoring alert

Departing aircraft assigned a departure runway that is not active for
departures when there is at least one active departure runway
(DRWY jtem shown with a red background)
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9 Tagitems and functions
The plugin includes a number of tag items and functions to use in EuroScope flight lists or track labels.

9.1 Tagitems
Arrival stand

Departure stand

Ground state

9.2 Tag functions
Open Ground state menu

Open Stand menu

Displays the assigned arrival stand. Colored with ES color “Emergency” if the
stand is occupied or blocked, “Information” if the assignment has changed.

Displays the departure stand (only as long as the aircraft is still there)

Displays the aircraft’s ground state using the plugin’s custom texts for them,
including the plugin specific ground states. The displayed text for each state is
adjustable using the plugin settings.

Opens the Ground state menu

Opens the Stand assignment menu. When the aircraft has a changed stand

assignment, instead of opening the menu, this tag function clears the
“Information” color.
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